Issue:

Cannot log into Mosaic

Cause:

The following are a few reasons why you may not be able login to Mosaic:

    • You will not be able to log into Mosaic on the same day that you activate your MacID.  If you just activated your MacID, please wait until the following day to log into Mosaic.

    • You are entering your email address as the login. Please enter only your MacID.

    • MacID password is incorrect.  Check if you are able to log into anything else that uses your MacID.

    • Mosaic undergoes maintenance every Thursday night from 6pm to 10pm, with the possibility of closures of sub-systems during this time.   Try logging into Mosaic after the maintenance period.

    • Browser caching issue: Follow the instructions to Clear the cache in web browsers

Solution:

If you are still having issues, please contact us.

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Phone: (905) 525-9140 x 23355