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About:

Are you having problems logging into OSCARPlus?

Cause:

Incorrect MAC ID/Password or ID not set up for access

UTS Support:

UTS does not provide support for OscarPlus.

University Technology Services (UTS) has the capability to assist with a complete reset of your MacID login credentials, including your password.

However, if you currently have access to other components of your account, such as Outlook, Teams, Mosaic, etc., we will not recommend proceeding with a full reset at this time.

You can verify your MAC ID and password using this: https://maciam.mcmaster.ca

Solution:


If the verification is successful and you are still unable to log in, please contact the Student Success Centre for technical support:


hey have a live chat on their website which can be contacted here. - https://studentsuccess.mcmaster.ca/about/oscarplus/

Student Success Centre is the department that manages OscarPlus:  https://studentsuccess.mcmaster.ca/about/contact-us/

For additional information: OSCARplus - Student Success Centre | McMaster University

Still need help with other IT issues or questions:

Chat with us: Click to chat

Submit Ticket: Click to submit a ticket

In-Person Support: Join the Line

Call Us: (905 525-9140 * 2Help (24357)


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