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About:  

Are you having problems logging into OSCARplus?

Cause:

  • Incorrect MacID/Password
  • Incorrect login entry (it uses macid@mcmaster.ca)
  • Browser issue
  • Access issue

UTS Support:

If you are unable to log into OSCARplus, here are some things you can check:

  • make sure you are entering your McMaster email address as the login and not just your MacID
  • does your MacID password work to log into any other systems such as Mosaic or Avenue to Learn?
  • try using a private/incognito window in your browser to log into OSCARplus.  You can also try using a different browser.

Solution:

If your MacID password is not working to log into any systems, you can reset your password by following the instructions on this page:   Forgot MacID Password 

If your password is working and your have tried using a private browser window but are still unable to log in, please contact the Student Success Centre as they manage the OSCARplus system. 

They have a live chat on their website:  https://studentsuccess.mcmaster.ca/about/oscarplus/  

Additional contact information can be found here:   https://studentsuccess.mcmaster.ca/about/contact-us/

Still need help with other IT issues or questions:

Chat with us: Click to chat

Submit Ticket: Click to submit a ticket

In-Person Support: Join the Line

Call Us: (905 525-9140 * 2Help (24357)


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