You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Next »

Description:

User is having problems logging into OSCARPlus

Cause:

Incorrect MAC ID/Password or ID not set up for access

Solution:

Have user verify that their MAC ID and password are correct: https://maciam.mcmaster.ca

If the verification is Successful and they are still unable to log in, refer them to the Student Success Centre:

For additional information: OSCARplus - Student Success Centre | McMaster University

Hello Customer,

I've confirmed that you'll want to reach out to the Student Success Centre for technical support with OscarPlus. They have a live chat on their website which can be contacted here. - https://studentsuccess.mcmaster.ca/about/oscarplus/

Student Success Centre is the department that manages OscarPlus:  https://studentsuccess.mcmaster.ca/about/contact-us/



  • No labels