Are you trying to sign in to Microsoft 365 apps and seeing a message that your device has been deleted?
Description:
Cannot sign into 365 applications - error message indicates the device is disabled or your organization has disabled this device.
Each time when you try and log into a Microsoft account, you get the message in the image pop up.
Environment:
Windows Computer, Microsoft 365
Cause:
Potential causes for this issue are listed below:
Changed the password and changing the password removed the account from your computer.
Updating the device to a new operating system.
Accidentally disabled the device OR device has been disabled by the administrator.
Sept-by-step guide:
If the device has been deleted in Microsoft Entra ID, you may need to re-register it by doing the following:
Go to Settings > Accounts > Access Work or School.
Select the account and if connected, select Disconnect. If not connected, go to step 3.
Select Connect and register the device again by going through the sign in process using your McMaster credentials.
Important:Make sure tofully complete the sign-in process, includingwaiting for each screen to load completelyandcompleting all required steps such as multi-factor authentication (MFA). If any part of the process is skipped or incomplete (e.g., closing the page while is still loading, or skipping MFA), the device may appear connected but will not function properly.
If the above does not work for you, please contact us and provide your device name. See steps below to check your device name.
Check disabled device name:
You can locate the disabled device name by doing the following: