Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Description

About:

Section
bordertrue

User is Are you having problems logging into OSCARPlus?

Cause:

Section
bordertrue

Incorrect MAC ID/Password or ID not set up for access

Solution
Have user verify that their MAC ID and password are correct: 

UTS Support:

Section
bordertrue

UTS does not provide support for OscarPlus.

University Technology Services (UTS) has the capability to assist with a complete reset of your MacID login credentials, including your password.

However, if you currently have access to other components of your account, such as Outlook, Teams, Mosaic, etc., we will not recommend proceeding with a full reset at this time.

You can verify your MAC ID and password using this:

Solution:

Hello Customer,

I've confirmed that you'll want to reach out to

please contact the Student Success Centre for technical support

with OscarPlus. They

:


hey have a live chat on their website which can be contacted here. - https://studentsuccess.mcmaster.ca/about/oscarplus/

Student Success Centre is the department that manages OscarPlus:  https://studentsuccess.mcmaster.ca/about/contact-us/

For additional information: OSCARplus - Student Success Centre | McMaster University

Section
bordertrue


If the verification is Successful successful and they you are still unable to log in, refer them to the Student Success Centre:

For additional information: OSCARplus - Student Success Centre | McMaster University

Expand
titleFor Technical Issues

Relevant useful links

Related Links

label in ("oscar","oscarplus"
Section
bordertrue
Content by Label
showLabelsfalse
max10
showSpacefalse
sorttitle
excludeCurrenttrue
cql

Still need help with other IT issues or questions:

Section

Chat with us: Click to chat

Submit Ticket: Click to submit a ticket

In-Person Support: Join the Line

Call Us: (905 525-9140 * 2Help (24357)